Results 1 to 9 of 9

Thread: State of the Dice Masters Vassal Module

  1. #1

    State of the Dice Masters Vassal Module

    Howdy,

    I wanted to give everyone an update on the Vassal module for Dice Masters and our progress and future plans.

    Me (simage) and Wargfn will be the current keepers of the Dice Masters Vassal module and will be responsible for keeping the module up to date, error free and posted onto the Vassal website.

    http://www.vassalengine.org/wiki/Mod...gers_vs._X-Men

    The latest version that is currently on the website is version 2.5 (I know there was a version 2.6 available, but it was removed to be corrected).

    We plan to release a version 2.5.1 some time after this weekend. This new version will have modified player mats to include an Out of Play area on the used space. Any dice I this area should not get relocated to the dice bag when you select the refill arrow. Hopefully this helps to keep things in line for future games. It will also have updated card images for the DC and D&D sets.

    We also plan to include a "preview" release for any next set cards that are made available early. We will also release a version 2.6 preview that will include all the Set 6 Age of Ultron cards and dice. When the set is officially released, we will upgrade it to 2.6.1 and update all images with real scans.

    Do hesitate to contact me or Wargfn with any issues or questions regarding the Vassal module for Dice Masters. We hope that it is a good resource for all players, especially for those that don't have a lot of local options to play.

  2. #2
    I appreciate your work and commitment to this endeavour. I have been using vassal to fish bowl deck ideas but I have yet to actually use it against another player. Thank you.

  3. #3

  4. #4
    Quote Originally Posted by RJRETRO View Post
    Is anyone else having trouble loading 2.5.1?
    What type of problem RJRetro? Won't load into the Module? or connect to the server?
    I have not had any issues, and I frequently, delete my old module and load the new one. I do get a message occasionally about teams being for a different version but thus far have had no issues from teams created in version 2.3 to present 2.6.

  5. #5
    @simage and @Wargfn , don't know if this is the problem that @RJRETRO is having, but a number of people reported problems with version 2.5. I worked out that it was due to corrupt downloads. And so hosted a copy of the module on my Google Drive. I think the module has got to the size, now, where it cannot be reliable downloaded from the VASSAL servers, for some people. Why this is I don't know. I never had any issue downloading any of the versions.

    @simage : this was another reason I had been thinking of reworking the module, and, in particular, splitting each set off in to an extension - that way the module and extension sizes would remain small.

  6. #6
    Quote Originally Posted by Scorpion0x17 View Post
    @simage and @Wargfn , don't know if this is the problem that @RJRETRO is having, but a number of people reported problems with version 2.5. I worked out that it was due to corrupt downloads. And so hosted a copy of the module on my Google Drive. @simage : this was another reason I had been thinking of reworking the module, and, in particular, splitting each set off in to an extension - that way the module and extension sizes would remain small.
    We talked about splitting the module into sets. Issues with splitting it off, issues with keeping it together. I have seen the connectivity loss issues downloading from the Vassal Site. We should talk to Ken about putting a secondary site perhaps here. I really don't want to be hosting the file from Dropbox or a Google Drive account.

    There is also the module patcher. that would fix the corrected downloads if we started using it, because it has a hash md5 sum match as part of the patcher.

  7. #7
    I cannot load the module. Vassal just freezes after I download it.

  8. #8
    Quote Originally Posted by RJRETRO View Post
    I cannot load the module. Vassal just freezes after I download it.
    Let's figure out how to talk. until then try this link

    Also what version of Vassal are you using? Are you trying to use Vassal, and then Open Module?

  9. #9
    3.2.15. I've got Vassal closed when I'm loading the module, but I've also tried it while it's open.

    Trying that link you suggested and... still nothing.

    WAIT. Just worked. Sweet. Transit zone and everything~

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •